最新消息:

Motor 0.3.2 发布,MongoDB 的 Python 驱动

业界新闻 admin 787浏览 0评论

Motor 0.3.2 发布,此版本兼容 MongoDB 2.2,2.4 和 2.6,最低要求 PyMongo 2.7.1。

此版本修复了在 “copy_database” 方法的 socket 泄漏,重写了 “Let Us Now Praise ResourceWarnings” 里面的问题和 bug。

获得最新版本:pip install --upgrade motor。更多内容请看这里

Motor 为 Tornado 提供了一个基于回调和 Future 机制的非堵塞的 MongoDB 驱动程序。Motor 封装了 PyMongo

安装:$ pip install motor

示例代码:

from tornado import gen
  
class NewMessageHandler(tornado.web.RequestHandler):
    @tornado.web.asynchronous
    @gen.coroutine
    def post(self):
        """Insert a message."""
        msg = self.get_argument('msg')
        db = self.settings['db']
  
        # insert() returns a Future. Yield the Future to get the result.
        result = yield db.messages.insert({'msg': msg})
  
        # Success
        self.redirect('/')
  
  
class MessagesHandler(tornado.web.RequestHandler):
    @tornado.web.asynchronous
    @gen.coroutine
    def get(self):
        """Display all messages."""
        self.write('<a href="/compose">Compose a message</a><br>')
        self.write('<ul>')
        db = self.settings['db']
        cursor = db.messages.find().sort([('_id', -1)])
        while (yield cursor.fetch_next):
            message = cursor.next_object()
            self.write('<li>%s</li>' % message['msg'])
  
        # Iteration complete
        self.write('</ul>')
        self.finish()

Motor API

转自:http://www.oschina.net/news/53697/motor-0-3-2-released

 

转载请注明:jinglingshu的博客 » Motor 0.3.2 发布,MongoDB 的 Python 驱动


Warning: Use of undefined constant PRC - assumed 'PRC' (this will throw an Error in a future version of PHP) in /usr/share/nginx/html/wp-content/themes/d8/comments.php on line 17
发表我的评论
取消评论

表情

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址